SCIRun User Mailing List

Text archives Help

[SCIRUN-USERS] installing SCIRun with PETSc

Chronological Thread 
  • From: Leon Graham <>
  • To:
  • Subject: [SCIRUN-USERS] installing SCIRun with PETSc
  • Date: Wed, 10 Nov 2004 16:25:07 +1100

Dear scirun-users

I am having problems installing SCIRun with PETSc on Fedora Core2 from the source code. Though, the installation of SCIRun without PETSc was successful.
I have followed the SCIRun installation guide for the PETSc installation for PETSC_ARCH=linux-gnu. Except at the build procedure I could not use the command "make all", I had to use

make BOPT=O       or          make BOPT=O_c++      etc......

The testing of PETSc was successful (i.e make BOPT=O test)

But when I entered the following command to build SCIRun:

../src/configure \
--with-thirdparty=/usr/local/scirun/SCIRun/Thirdparty/1.22/Linux/gcc-3.3.3-32bit/ \
--enable-package="BioPSE MatlabInterface Teem" \

I got the following output:

configure: WARNING: Specified unipetsc directory is invalid. One of the followi ng dirs does not exist:
configure: WARNING: /home/lgraham/petsc-2.1.6//lib/libO/linux
configure: WARNING: /home/lgraham/petsc-2.1.6//include/mpiuni
configure: WARNING: /home/lgraham/petsc-2.1.6//bmake/linux
configure: error: Please fix this problem and reconfigure.
[root@plmf307lgraham linux]#

I suspect that it was the operating system type and SCIRun build procedure, because the build procedure was looking for the linux directories instead of linux-gnu directories. I tried to over come this by changing the directory names from "linux to "linux-gnu", and copying the "mpiuni" directory from "/petsc-2.1.6/src/sys/src" into "/petsc-2.1.6/include" directory, but without success.
I got the following output:

checking for lapack library (optional)... yes
checking for mpi-uni libraries and headers (optional)... yes
checking for petsc libraries and headers (optional)... not found
checking for petsc-uni libraries and headers (optional)... not found

configure: error: One or more of the UNI-PETSC components is missing.
[root@plmf307lgraham linux]#

I tried to install PETSc for "PETSC_ARCH=linux, but when I entered the command:

./config/ --with-mpi=0 --with-blas-lapack-dir=/usr/lib

I got the following output:

Configuring PETSc.packages.Triangle
Configuring PETSc.packages.ParMetis
Configuring PETSc.packages.PLAPACK
Configuring PETSc.packages.PVODE
Configuring PETSc.packages.BlockSolve
Configuring PETSc.packages.NetCDF
Configuring PETSc.Configure
PETSC_ARCH (linux) does not have our guess (linux-gnu) as a prefix!
[lgraham@plmf307lgraham petsc-2.1.6]$

So I could not install PETSc for "PETSC_ARCH=linux"

Does anyone know how to overcome this SCIRun/PETSc installation problem?


== The SCIRun Users mailing list: send email to   ==
== for more details.                                                     ==
== Please acknowledge use of SCIRun in your papers and reports:          ==
==   see         ==

Archive powered by MHonArc 2.6.16.

Top of page