SCIRun User Mailing List

Text archives Help

[SCIRUN-USERS] ApplyFEMVoltageSource module crashes

Chronological Thread 
  • From: Ashu Chaturvedi <>
  • To:
  • Subject: [SCIRUN-USERS] ApplyFEMVoltageSource module crashes
  • Date: Tue, 14 Feb 2012 12:08:48 -0500


I'm running into a problem with the ApplyFEMVoltageSource module in SCIRun v4.5.

Every time I run the module with inputs that I know worked in v3.0.2, it gives me the following error and crashes/exits:

Thread "ApplyFEMVoltageSource" (id: 0x1088ad000, pid: 2516) 
        caught signal SIGSEGV at address 0 (segmentation violation)
0x7fff72c9c960:main( RUNNING, List: )
0x102df1000:internal service manager(detached,  RUNNING, List: )
0x104041000:Event Manager Thread(detached,  BLOCKING, EventManager, List: )
0x104084000:Scheduler(daemon, detached,  BLOCKING, NetworkEditor request FIFO, List: )
0x104301000:TCL main event loop(detached,  RUNNING, List: )
0x104541000:ReadField( BLOCKING, Module execution FIFO, List: )
0x104741000:ImportMatricesFromMatlab( BLOCKING, Module execution FIFO, List: )
0x108c41000:ImportMatricesFromMatlab( BLOCKING, Module execution FIFO, List: )
0x1088ad000:ApplyFEMVoltageSource( RUNNING, List: )

Abort signalled by pid: 2516
Occured for thread: "ApplyFEMVoltageSource"

Do you have any ideas what might be wrong?  These same inputs work fine in v3.0.2.  The input data files I'm using are located here:

Feel free to download it and check for yourself.  The files are labeled input1 (field mesh), input2 (stiffness matrix), input3 (right-hand side).  Hopefully that will help.

Thanks in advance for your help!

--Ashu Chaturvedi

Archive powered by MHonArc 2.6.16.

Top of page