SCIRun User Mailing List

Text archives Help

[SCIRUN-USERS] RE: Defibrillation tutorial.

Chronological Thread 
  • From: "Kharche, Sanjay" <>
  • To: Jess Tate <>
  • Cc: "" <>
  • Subject: [SCIRUN-USERS] RE: Defibrillation tutorial.
  • Date: Sun, 4 Aug 2013 15:10:59 +0000
  • Accept-language: en-GB, en-US

Hi Jess

Thanks for the pointers. I have as yet not been able to carry out sec. 4.1 visualisation and the details are as follows.

I downloaded the data again, this time the tgz file rather than the zip file. I noticed that the torso_segmentation_si.fld file is the same file size in both the zip and tgz distributions. So perhaps the data are not corrupt. After constructing the network, checking the X,Y,Z in the textureslices module, I left the colormap unaltered, and the output is the image as attached. I can see the slice planes, and the slice widget, but no torso. I tried to go thru' the slices using the buttons in the textureslices, but could not see much.

About errors, there is a dos prompt like window that comes up when running SCIRun in windows. In this window, when I reach the view (using the view scene module) stage, I get an error:
I/O error: no such file or directory
In fact, when I select, set and execute the torso_segmentation_si.fld in the ReadFld module, I get this error. So I think somehow, the data is just not being read. Another error to mention may be that once the network is ready, and I get the view as in the attached png, I tried to confirm that the fld file is correct. When I open the ReadFld UI, I see that an electrode*.fld is in the file field, not torso_segmentation_si.fld.

Can you comment?


From: Jess Tate []
Sent: 04 August 2013 06:00
To: Kharche, Sanjay
Subject: Re: [SCIRUN-USERS] Defibrillation tutorial.

Hi Sanjay,

If you do not see anything in the view window, you should make sure that the x y and z planes have been checked in the showtextureslice UI.  If there are no errors then that is the most likely issue.  It helps to see leave the color map unaltered at first (do not make zero transparent).  If you see the slice widget (looks like a small sphere) but nothing else, you may have moved it off the volume.  create a new shotextureslices module (and select the planes).  If that doesn't work or you see slices that are gray or all blue, then the data could be corrupted.  Make sure you are loading the correct file (torso_segmentation_si.fld) from the SCIRunData file.  You may need to download the data again.  

This should work.  The only thing that you have to change in the modules is checking the planes as mentioned.  Don't change any other settings in the module (at first).  There is an off chance that there are some graphics card compatibility issues since the texture data is meant to use the shader functionality in the hardware, however I haven't seen major problems with this module, especially if you haven't had any other graphics issues with SCIRun.  


On Aug 3, 2013, at 9:49 AM, Kharche, Sanjay wrote:


I am using the windows 64 bit version 4.6 of SCIRun to work thru' the defibrillation tutorial.

With reference to the pdf tutorial, I am trying to implement "sec. 4.1 Loading the Data set". I have attempted the instructions several times, and my network looks like fig 4.1. However, when I try to view the result, I cannot see the torso. It seems the data is not being read in, although the Read module does have the fld file in it. Please can someone indicate what could be missing.

many thanks

Attachment: notorso_seg_sifld.png
Description: notorso_seg_sifld.png

Archive powered by MHonArc 2.6.16.

Top of page