SCIRun User Mailing List

Text archives Help

Re: [SCIRUN-USERS] scirun5 with tests

Chronological Thread 
  • From: Dan White <>
  • To: Petar Petrov <>,
  • Cc: Ayla Khan <>
  • Subject: Re: [SCIRUN-USERS] scirun5 with tests
  • Date: Thu, 03 Jul 2014 10:30:50 -0600

Upgrading to Qt 5 is on our todo list, but we're only vaguely aware of OpenGL-related changes made from 4.x that may affect our codebase substantially. Since our graphics dev just left, and a new one starts next week, this task is in flux. But if you have any experience on the Qt/OpenGL front that would be helpful. We're thinking it may affect Windows and Mac more than Linux.

As for module porting, it's a painstaking procedure to "upgrade" each module. Probably the best way to learn is to start with diffing v4 and v5 versions of the same module, and just follow the commits as I convert them--they usually go in the same pattern. So far I've only trained one other post-doc how to do it, and it took about a month of sporadic explanations/Q&A. So if you're up for it, it's a pretty high hurdle, but once surmounted, it's pretty straightforward. And we have a big training class in a couple weeks so I will be slower to answer questions, but after 7/24 I'll be more available.


On 7/3/2014 5:49 AM, Petar Petrov wrote:
Hi Ayla,
indeed it all seems working under Ubuntu 14.04. So I have scirun5 with
tests running.
I had to do some switching from Qt5 (default in 14.04) to Qt4 (since
scirun5 only builds with 4.x).
I have yet another project using Qt5, do you have some experience
switching between the two?
Anyway, I will be glad to help you with the porting guys. Let me know.


On Tue, Jul 1, 2014 at 8:58 PM, Petar Petrov <> wrote:
Hi Ayla,
I just got a ubuntu12.04 setup today. Will give it a try and let you
know how it went. I really want to help you guys with the porting of
some modules.


On Tue, Jul 1, 2014 at 1:36 AM, Ayla Khan <> wrote:
No errors with GCC 4.8.2 (Ubuntu 4.8.2-19ubuntu1) on Ubuntu 14.04 LTS.


On Jun 30, 2014, at 11:49 AM, Dan White wrote:

That's the same error that shows up on our Travis-CI builds, for example:

I tried the -lrt fix and I managed to get a Ubuntu + clang build working on
Travis, but not gcc. Would switching to clang work for your purposes?

On 6/30/2014 9:19 AM, Petar Petrov wrote:
Hi Ayla,

$c++ --version, results in:

c++ (Ubuntu 4.8.1-2ubuntu1~12.04) 4.8.1

On Mon, Jun 30, 2014 at 4:58 PM, Ayla Khan <> wrote:
Hi Petar,

Which GCC compiler version are you building with?



On Jun 29, 2014, at 12:28 PM, Petar Petrov wrote:

I've just managed to build scirun5, however when I try building with
tests i got the following linker error:

[ 83%] Built target Testing_Utils
Linking CXX executable ../../../../Algorithms_Field_Tests
../../../../lib/ undefined reference to

I found people having some really strange ordering issues with the flag: -lrt

any help?

All the best,
Petar Petrov

Archive powered by MHonArc 2.6.18.

Top of page