SCIRun User Mailing List

Text archives Help

Re: [SCIRUN-USERS] Error in Build leadfield module

Chronological Thread 
  • From: Jess Tate <>
  • Cc: Purbasha Garai <>,
  • Subject: Re: [SCIRUN-USERS] Error in Build leadfield module
  • Date: Wed, 9 Sep 2015 07:58:16 +0200

You are also using the buildLeadfieldmatrix incorrectly.  See the forward inverse toolkit doc: or the example network:  SCIRun/src/Packages/BioPSE/nets/Samples/forward-leadfield-fem.srn.  Make sure that your SCIRunData path is set properly.


On Sep 8, 2015, at 11:33 PM, Brett Burton <> wrote:


I ran your network and found two things that are concerning.  One you may need to double check on your system to make sure that the files that you sent transferred correctly.

1 - The BuildFEMatrix module indicates that your mesh has negative Jacobians.  If this is truly the case, the module cannot function as it was written to do and your assigned conductivities within the space will not be correct.  You can check to see if you have any negative Jacobians by using the GetMeshQualityField module and selecting Jacobian in the UI options.  Attach a ReportFieldInfo to this and look at you min/max values.  You should have nothing less than 0.  You might be able to fix this with the CleanUpTetMesh module, though when I just tried, it did not remove all negative tets.

2 - The nodes that you sent are not actually within the volume.  The appear to not even touch the volume, therefore, any potential value that you apply to these electrodes will not be able to influence the axon.  I've attached a picture below (green orbs are your electrode sites blue are projections of the electrodes onto the mesh nodes).  These nodes are (as the error message suggests) out of range.  Try to project the nodes to the surface.  You can try using the ProjectPointsOntoMesh module to see if that works once you have confirmed that your mesh has no negative jacobians.

Hope that helps,

Brett Burton

PhD Candidate in Bioengineering | University of Utah

<Screen Shot 2015-09-08 at 3.33.04 PM.png>

On Sep 7, 2015, at 6:07 PM, Purbasha Garai <> wrote:


I am getting an error when I am running LeadField module. The error says,"Mesh out of Range". I am using the following .srn file to generate leadfield. I am attaching the mesh I am using as well as the error message. 

Your help will be really appreciated. 

Thank you 

Archive powered by MHonArc 2.6.18.

Top of page