SCIRun User Mailing List

Text archives Help

[SCIRUN-USERS] Building Error on Linux Arch

Chronological Thread 
  • From: Dafang Wang <>
  • To:
  • Subject: [SCIRUN-USERS] Building Error on Linux Arch
  • Date: Fri, 26 Jan 2018 18:28:45 -0500


I got errors when building SCIRun v4.x on Linux Arch. I tried several 4.x versions, as well as SCIRun linux and source packages, but all returned the same error shown below. The error seems to have do with tcl/tk. 

Also I got errors when building SCIRun v5. It seems that SCIRun requires Qt 4 whereas my computer is using Qt 5.

Any suggestions would be greatly appreciated. Thanks!


Error message of buiding v4.7:

[ 20%] Building C object Externals/tcltk/tcl8.6b1/CMakeFiles/tcl.dir/generic/tclMain.c.o
[ 20%] Building C object Externals/tcltk/tcl8.6b1/CMakeFiles/tcl.dir/generic/tclNamesp.c.o
[ 20%] Building C object Externals/tcltk/tcl8.6b1/CMakeFiles/tcl.dir/generic/tclNotify.c.o
[ 20%] Building C object Externals/tcltk/tcl8.6b1/CMakeFiles/tcl.dir/generic/tclObj.c.o
[ 20%] Building C object Externals/tcltk/tcl8.6b1/CMakeFiles/tcl.dir/generic/tclPanic.c.o
[ 20%] Building C object Externals/tcltk/tcl8.6b1/CMakeFiles/tcl.dir/generic/tclParse.c.o
[ 20%] Building C object Externals/tcltk/tcl8.6b1/CMakeFiles/tcl.dir/generic/tclPathObj.c.o
[ 20%] Building C object Externals/tcltk/tcl8.6b1/CMakeFiles/tcl.dir/generic/tclPipe.c.o
/home/dwang/program/SCIRun_4.7_20160120_source/src/Externals/tcltk/tcl8.6b1/generic/tclPipe.c: In function ‘TclCleanupChildren’:
/home/dwang/program/SCIRun_4.7_20160120_source/src/Externals/tcltk/tcl8.6b1/generic/tclPipe.c:271:22: error: storage size of ‘waitStatus’ isn’t known
     WAIT_STATUS_TYPE waitStatus;
/home/dwang/program/SCIRun_4.7_20160120_source/src/Externals/tcltk/tcl8.6b1/generic/tclPipe.c:271:22: warning: unused variable ‘waitStatus’ [-Wunused-variable]
make[2]: *** [Externals/tcltk/tcl8.6b1/CMakeFiles/tcl.dir/build.make:1215: Externals/tcltk/tcl8.6b1/CMakeFiles/tcl.dir/generic/tclPipe.c.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:923: Externals/tcltk/tcl8.6b1/CMakeFiles/tcl.dir/all] Error 2
make: *** [Makefile:130: all] Error 2

Error message of building v5:
-- Found unsuitable Qt version "5.10.0" from /usr/bin/qmake
CMake Error at /usr/share/cmake-3.10/Modules/FindQt4.cmake:1320 (message):
  Found unsuitable Qt version "5.10.0" from /usr/bin/qmake, this code
  requires Qt 4.x
Call Stack (most recent call first):
  Superbuild.cmake:118 (FIND_PACKAGE)
  CMakeLists.txt:39 (INCLUDE)

-- Configuring incomplete, errors occurred!
See also "/home/dwang/program/scirun5/SCIRun/bin/CMakeFiles/CMakeOutput.log".

***ERROR in build script
The failed command was:

Archive powered by MHonArc 2.6.18.

Top of page