SCIRun User Mailing List

Text archives Help

Re: [SCIRUN-USERS] Building Error on Linux Arch

Chronological Thread 
  • From: Dan White <>
  • To:
  • Cc:
  • Subject: Re: [SCIRUN-USERS] Building Error on Linux Arch
  • Date: Mon, 29 Jan 2018 13:58:21 -0700

I recommend following Petar's patch changes, and also try to compile with gcc 6 rather than 7--I bet there would be even more problems using 7. 

On Sun, Jan 28, 2018 at 8:09 PM, Dafang Wang <> wrote:

Hi Dan,

Thanks for your tips. I tried your suggested fix but still got the same error. My compiler is gcc 7.2.1.

Petar, thanks for sharing your experience. I will try your method.


On 01/28/2018 07:48 AM, Petar Petrov wrote:
So, I also faced troubles compiling on ubuntu 17.04 and with gcc 6.3.
Yesterday I finally decided to tackle it so I can run it on my newest desktop, so here is the change log that let to successful build:

As you can see, quite more than the patched offer for this particular err in tcl.

My feeling is that gcc6x compiles in c++11 or up profile by default !?

Maybe isolate as patch? Of course you can simply fetch from my repo of scirun4plus.
I will maintain it till at least this summer. I have a couple of papers in the making that use this version.


On Sat, Jan 27, 2018 at 12:53 AM, Dan White <> wrote:

4) What compiler version are you using? I found this possible fix by searching the error message, but of course there's no guarantee you won't get more errors compiling later. Since SCIRun on Arch is unsupported by SCI, you can start by following all the requirements listed on; if there are still problems you'll have to resort to the community.

5) Just download Qt 4 and install wherever you want, then point the build to that qmake rather than /usr/bin version. For instance, there is a package available at


On 1/26/2018 4:28 PM, Dafang Wang wrote:


I got errors when building SCIRun v4.x on Linux Arch. I tried several 4.x versions, as well as SCIRun linux and source packages, but all returned the same error shown below. The error seems to have do with tcl/tk. 

Also I got errors when building SCIRun v5. It seems that SCIRun requires Qt 4 whereas my computer is using Qt 5.

Any suggestions would be greatly appreciated. Thanks!


Error message of buiding v4.7:

[ 20%] Building C object Externals/tcltk/tcl8.6b1/CMakeFiles/tcl.dir/generic/tclMain.c.o
[ 20%] Building C object Externals/tcltk/tcl8.6b1/CMakeFiles/tcl.dir/generic/tclNamesp.c.o
[ 20%] Building C object Externals/tcltk/tcl8.6b1/CMakeFiles/tcl.dir/generic/tclNotify.c.o
[ 20%] Building C object Externals/tcltk/tcl8.6b1/CMakeFiles/tcl.dir/generic/tclObj.c.o
[ 20%] Building C object Externals/tcltk/tcl8.6b1/CMakeFiles/tcl.dir/generic/tclPanic.c.o
[ 20%] Building C object Externals/tcltk/tcl8.6b1/CMakeFiles/tcl.dir/generic/tclParse.c.o
[ 20%] Building C object Externals/tcltk/tcl8.6b1/CMakeFiles/tcl.dir/generic/tclPathObj.c.o
[ 20%] Building C object Externals/tcltk/tcl8.6b1/CMakeFiles/tcl.dir/generic/tclPipe.c.o
/home/dwang/program/SCIRun_4.7_20160120_source/src/Externals/tcltk/tcl8.6b1/generic/tclPipe.c: In function ‘TclCleanupChildren’:
/home/dwang/program/SCIRun_4.7_20160120_source/src/Externals/tcltk/tcl8.6b1/generic/tclPipe.c:271:22: error: storage size of ‘waitStatus’ isn’t known
     WAIT_STATUS_TYPE waitStatus;
/home/dwang/program/SCIRun_4.7_20160120_source/src/Externals/tcltk/tcl8.6b1/generic/tclPipe.c:271:22: warning: unused variable ‘waitStatus’ [-Wunused-variable]
make[2]: *** [Externals/tcltk/tcl8.6b1/CMakeFiles/tcl.dir/build.make:1215: Externals/tcltk/tcl8.6b1/CMakeFiles/tcl.dir/generic/tclPipe.c.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:923: Externals/tcltk/tcl8.6b1/CMakeFiles/tcl.dir/all] Error 2
make: *** [Makefile:130: all] Error 2

Error message of building v5:
-- Found unsuitable Qt version "5.10.0" from /usr/bin/qmake
CMake Error at /usr/share/cmake-3.10/Modules/FindQt4.cmake:1320 (message):
  Found unsuitable Qt version "5.10.0" from /usr/bin/qmake, this code
  requires Qt 4.x
Call Stack (most recent call first):
  Superbuild.cmake:118 (FIND_PACKAGE)
  CMakeLists.txt:39 (INCLUDE)

-- Configuring incomplete, errors occurred!
See also "/home/dwang/program/scirun5/SCIRun/bin/CMakeFiles/CMakeOutput.log".

***ERROR in build script
The failed command was:

SCIRun users mailing list:
To unsubscribe, email with the "unsubscribe scirun-users" in the message body.

SCIRun users mailing list:
To unsubscribe, email with the "unsubscribe scirun-users" in the message body.

All the best,
Petar Petrov

SCIRun users mailing list:
To unsubscribe, email with the "unsubscribe scirun-users" in the message body.

SCIRun users mailing list:
To unsubscribe, email with the "unsubscribe scirun-users" in the message body.

Archive powered by MHonArc 2.6.18.

Top of page