SCI Seg3D Mailing List

Text archives Help

RE: [Seg3D] installation from source

Chronological Thread 
  • From: "Ozerov Dmitry (PSI)" <>
  • To: Jess <>
  • Cc: "" <>
  • Subject: RE: [Seg3D] installation from source
  • Date: Wed, 30 May 2018 05:38:20 +0000
  • Accept-language: en-US, de-CH

  Hi Jess,
 thanks a lot for the fast reply. I'll try with different branch. For qt5 (which is installed, not built.
May be some qt5 library still missing?), please check screenshot, may be it helps to identify
which part of qt5 is missing/broken?


From: Jess Tate [] on behalf of Jess []
Sent: Wednesday, May 30, 2018 12:15 AM
To: Ozerov Dmitry (PSI)
Subject: Re: [Seg3D] installation from source

Hi Dmitry,

When you get it built, do you see any of the icons or viewer tools, or is the whole viewer gray?  there is probably and issue with the qt5 build.

for installing 2.2.1, you will have to modify Superbuild/ITKExternal.cmake file to change the branch it is trying to download.  On line 89 or so, change git tag to master, ie, SET(itk_GIT_TAG “origin/master”).


On May 27, 2018, at 1:58 AM, Ozerov Dmitry (PSI) <> wrote:

  Dear Support Team,

 i tried to install 2.4.2 from source on CentOS7.4. To install one needs to have
subversion installed as well as qt5-qtbase{-devel}, qt5-qtsvg{-devel}. Then 
the installation went without complaints, but the installed Seg3D crashed with
segmentation fault when any "new project" or "open project" button was pressed.
Experimentally we found that installation of qt5-qttools-devel helped, program
don't crash anymore, but after opening the project the panels are grey(empty)
(the central and three lateral, where one expects to see something). Here i need
to mention also that we try this installation on remote (not local) workstation, and
currently Seg3D is opened in NoMachine window (via ssh it doesn't work).

 I also tried to install 2.2.1, but there the build process had problem at this step:

[ 42%] Performing download step (git clone) for 'ITK_external'

cd /opt/psi/MX/Seg3D/2.2.1/bin/Externals/Source && /usr/bin/cmake -P /opt/psi/MX/Seg3D/2.2.1/bin/Externals/tmp/ITK_external/ITK_external-gitclone.cmake

Cloning into 'ITK_external'...

remote: Counting objects: 405185, done.

remote: Total 405185 (delta 0), reused 0 (delta 0), pack-reused 405184

Receiving objects: 100% (405185/405185), 314.95 MiB | 25.38 MiB/s, done.

Resolving deltas: 100% (322812/322812), done.

Checking connectivity... done.

Checking out files: 100% (13696/13696), done.

error: pathspec 'origin/seg3d_external_test' did not match any file(s) known to git.

CMake Error at /opt/psi/MX/Seg3D/2.2.1/bin/Externals/tmp/ITK_external/ITK_external-gitclone.cmake:49 (message):

  Failed to checkout tag: 'origin/seg3d_external_test'

 Any help or advices will be appreciated.



Seg3d mailing list:
To unsubscribe, email with the "unsubscribe seg3d" in the message body.

Attachment: seg3d.png
Description: seg3d.png

Archive powered by MHonArc 2.6.18.

Top of page