SCIRun User Mailing List

Text archives Help

[SCIRUN-USERS] Re: Some problems loading data from Seg3D to Seg3D2

Chronological Thread 
  • From: Ramón Casero Cañas <>
  • To: Jeroen Stinstra <>
  • Cc: Mailing list SCIRun <>
  • Subject: [SCIRUN-USERS] Re: Some problems loading data from Seg3D to Seg3D2
  • Date: Wed, 21 Sep 2011 16:48:39 +0100

On 21/09/11 16:24, Jeroen Stinstra wrote:
Hi Ramon,

Could you send me an example of the matlab file and the nrrd file? I fear 
some recent change in the code may have broken code for matlab files, but I'd 
like to confirm that with your matlab file, so I can engineer a solution.  
Concerning the nrrd format, it reports that the file is not valid, we have 
had more problems with the old version of Seg3D writing incorrect nrrd files 
as it did not use the right library calls to write out the files. I have 
already added code to fix faulty output from the older versions, but I think 
we must have missed a few cases, hence if you could send me an example I can 
add code to ensure we can read those files as well. The spacing should not be 
an issue.

Note, to export in matlab format from Seg3D2, just click on the layer with 
the right mouse button, a menu will appear allowing to export to different 

Hi Jeroen,

Thanks for the advice.

I have created a small crop of the volume, so that it's easier to deal with.

This foo.mat didn't make Seg3D2 crash the first time I tried to load it with "Quick open file", it gave an error message without crashing. Then I tried to load it again, and the application crashed with a "Segmentation fault".

The foo.mat file has been created by "Save Volume" in Seg3D. This is the branch of Seg3D I'm using

The attached nrrd file fails to load in Seg3D2 too. It was created with "Save Volume" in Seg3D

ERROR: Could not read file '/home/ramc/elham/image-processing/foo.nrrd'.
Could not open file: /home/ramc/elham/image-processing/foo.nrrd : [nrrd] nrrdLoad: trouble reading "/home/ramc/elham/image-processing/foo.nrrd"
[nrrd] nrrdRead: trouble
[nrrd] _nrrdRead: trouble reading NRRD file
[nrrd] _nrrdFormatNRRD_read: trouble parsing spacings info "0.000000 0.000000 0.000001"
[nrrd] _nrrdReadNrrdParse_spacings: trouble
[nrrd] _nrrdFieldCheck_spacings: axis 0 spacing (0) invalid

Best regards,


Dr. Ramón Casero Cañas

Computational Biology
Department of Computer Science
University of Oxford
Wolfson Building, Parks Rd
Oxford OX1 3QD

tlf     +44 (0) 1865 610737

Attachment: foo.mat
Description: Binary data

Attachment: foo.nrrd
Description: Binary data

Archive powered by MHonArc 2.6.16.

Top of page