SCIRun User Mailing List

Text archives Help

Re: [SCIRUN-USERS] module problem

Chronological Thread 
  • From: DANIEL WHITE <>
  • To: Vikas R bhat <>
  • Cc: Jess <>,
  • Subject: Re: [SCIRUN-USERS] module problem
  • Date: Fri, 27 Oct 2017 09:25:54 -0600

You'll need a fork of SCIRun created by the author of that paper, who wrote those (non-official) missing modules. The code is here, and the author is active on this email list so I refer you to him for support of those modules.

On Thu, Oct 26, 2017 at 10:31 AM, Vikas R bhat <> wrote:
Thank  u/..
Respected Daniel,

I tried as you suggested (by default it moves to the referred path.). But I am getting the same errors. And as mentioned in recent paper "How much detail is needed in modeling a transcranial magnetic stimulation figure-8 coil: Measurements and brain simulations", the module/s under Math dataflow are newly developed which comes in TMS. As it contained BiotSavartSolver (SolveBiotSavartContour), I wanted to use that module which seems to be not displaying under Math but is in src ( xml, .cc and .h files are there). 

Inline image 2

Inline image 3

On Wed, Oct 25, 2017 at 11:07 PM, DANIEL WHITE <> wrote:
The Windows executable you named from that page is an installer. Just run it and then SCIRun is installed (by default to C:\Program Files\SCIRun 4), no need to copy source files anywhere.

On Tue, Oct 24, 2017 at 4:31 PM, Jess <> wrote:
I don’t know if we have tested scirun 4 on widows 10, so it is possible it doesn’t work on that os.  If you are using an older one, it should work.  You can try reinstalling.


On Oct 24, 2017, at 12:06 PM, Vikas R bhat <> wrote:

Os is Windows 64bit.

I copied the src to the existing scirun which i downloaded from 


Even I tried checking the same with 4.6 version, I am getting the same errors. 

Do I need to re install the .exe file..?

It is mentioned as scirun 4.7plus src.. Do we have .exe file for 4.7+ version.? 

Thnk u. 

On 24-Oct-2017 10:58 PM, "Jess" <> wrote:
Hi Vikas,

It looks like you haven’t installed SCIRun 4.7 correctly.  What OS are you running and how did you install it?


On Oct 24, 2017, at 11:26 AM, Vikas R bhat <> wrote:

Respected Jess,

I downloaded the recent scirun 4.7 plus source codes and copied it to the scirun path. I am getting errors when I open SCIRUN. Some of the modules are not displayed.

It shows: Unable to load all of package  'SCIRUN' <category 'TMS' failed>: The specified module could not be found.

Unable to load all of package  'SCIRUN' <category 'Utility' failed>: The specified module could not be found.

I checked the source code paths: XML, .cc, .h files are correctly copied in their respective places. Please help me in fixing this error.
Waiting for your reply.



SCIRun users mailing list:
To unsubscribe, email with the "unsubscribe scirun-users" in the message body.



PNG image

PNG image

Archive powered by MHonArc 2.6.18.

Top of page