SCIRun User Mailing List

Text archives Help

RE: [SCIRUN-USERS] RE: Visualization window crashes after compilation

Chronological Thread 
  • From: "Jolley, Matthew" <>
  • To: "Ian Miller" <>, "scirun users group" <>
  • Subject: RE: [SCIRUN-USERS] RE: Visualization window crashes after compilation
  • Date: Mon, 17 Sep 2007 17:42:09 -0400

This sounds similar to our problems on Fedora machines with Livna nvidia 
drivers at the Surgical Planning Laboratory.  glxgears would run fine, but 
SCIRun was not finding the correct drivers and would crash on opening 
anything OpenGL dependent.  I am just an MD end user, and most of this is 
based on what the SCI folks have given me, so I defer to them.  
That said it might be worth checking the following:
when you cd to SCIRun/bin and run:
ldd scirun | grep GL
What do you should point to the intel/i810 drivers...if it does not 
then you might have a similar problem to what we faced...
We worked around SCIRun finding the wrong drivers (MESA rather than the 
accelerated ones) by pointing it to the correct drivers as specified here 
(the script is not visible from the outside SPL, but might be something to 
point the SCI guys to).
I may be off base and defer to the SCI experts, but it sounds similar to the 
problem we were having.
I have had not had trouble with ubuntu/nvidia but have never used it with an 
integrated graphics card.  
Good luck,
Matthew Jolley, MD
Children's Hospital Boston 
Pager 6132


From: on behalf of Ian Miller
Sent: Mon 9/17/2007 16:36
To: scirun users group
Subject: [SCIRUN-USERS] RE: Visualization window crashes after compilation

Tried updating the driver from 'i810' to 'intel', which appears to be more 

I'm not sure I did it right, but did it using the Adept  Package manager. 
When I selected 'intel' to install, it automatically uninstalled i810. So far 
so good, but when I opened the KDE system settings to confirm that the driver 
had changed under 'monitor and settings' -> 'hardware', it still said  'i810'.

Editing /etc/X11/xorg.conf to change the driver manually from i810 to intel 
did not change anything.


sudo dpkg-reconfigure xserver-org

and reconfiguring with curses-style interface changed neither the SCIRun 
functionality or the video driver listed in KDE 'System Settings'.

The silver lining is that glxgears still works  :[

Thanks for the ideas


"Jolley, Matthew" <> wrote: 

        Sorry, meant this link... if using current version...
        Matthew Jolley, MD
        Children's Hospital Boston 
        Pager 6132


Catch up on fall's hot new shows 
  on Yahoo! TV. Watch previews, get listings, and more! 

== The SCIRun Users mailing list: send email to   ==
== for more details.                                                     ==
== Please acknowledge use of SCIRun in your papers and reports:          ==
==   see         ==

Archive powered by MHonArc 2.6.16.

Top of page