SCIRun User Mailing List

Text archives Help

Re: [SCIRUN-USERS] OpenGL Issues?

Chronological Thread 
  • From: tom fogal <>
  • To:
  • Subject: Re: [SCIRUN-USERS] OpenGL Issues?
  • Date: Tue, 25 Mar 2014 18:15:34 +0100


Hrm, your glxinfo looks totally valid. You might try upgrading the OGL drivers, you're at 319.37 and the latest are 331.49 or 334.21 depending on how you count.

But it sounds to me like the bug doesn't lie in your OpenGL setup; SCIRun is the most likely culprit. I'm afraid you'll need someone with more SCIRun expertise than me to dig deeper.

If you can send Subsample's output to WriteField and write out that tiny NRRD, I'm sure it would help them debug.


On 03/25/2014 05:40 PM, Hyde, Damon wrote:
Hey Tom,
glxgears runs just fine. I tried turning SLI off, but am still
having the same issue with ConvertFieldsToTexture. The pipeline I'm
using currently looks like:

ReadField -> SubsampleStructuredFieldByIndices -> ConvertFieldsToTexture

I'm using the second module to chop out most of the data in the NRRD,
leaving just a 5x5x5 volume.

Attached is the output of glxinfo.


On 03/25/2014 11:46 AM, tom fogal wrote:
Hi Damon!

Does 'glxgears' work?

Given that the second cards are teslas, you probably want to disable
SLI. Try:

nvidia-xconfig --sli=off

I believe you need to restart your X server after you do that.

If you have no luck there, posting the output of 'glxinfo' to the list
may be useful. Make sure to capture both stdout && stderr when logging
it. IIRC glxgears and glxinfo are in the 'glx-utils' package on RH/CentOS.

All that said, if 'ShowField' is working then your OpenGL setup is
probably okay. Might just be a bug in ConvertFieldsToTexture. Reducing
the pipeline as much as possible and using a (faked) tiny data file
would probably help debug.


On 03/24/2014 08:28 PM, Hyde, Damon wrote:
I'm having some issues with SCIRun that I believe are related to the
video drivers and OpenGL. Specifically, I have compiled SCIRun 4.7 on a
workstation running CentOS 6.5. The build script completes, and SCIRun
opens fine. I'm using ReadField to input a NRRD file, and can visualize
it with showField.

The issue arises with ConvertFieldsToTexture. The module seems to start
running, but never completes (or even shows a bit of progress). From
looking at the documentation a bit, it seems that this module relies on
OpenGL to run properly?

The workstation I'm running on has not one, but three different NVIDIA
cards installed in it. A Quadro 6000 card and two Tesla 2050 cards.
I've tried compiling SCIRun with the drivers from the CUDA toolkit, as
well as the standalone NVIDIA drivers. Everything seems to check out as
far as having the drivers installed properly, but I'm guessing my issues
with SCIRun somehow stem from the unusual configuration. Does anyone
have ideas for a potential solution to this issue?

Also just tried this with the latest trunk release and got the same issues.


Archive powered by MHonArc 2.6.18.

Top of page