SCIRun User Mailing List

Text archives Help

Re: [SCIRUN-USERS] OpenGL Issues?

Chronological Thread 
  • From: Ayla Khan <>
  • To: "Hyde, Damon" <>
  • Cc: tom fogal <>, "" <>
  • Subject: Re: [SCIRUN-USERS] OpenGL Issues?
  • Date: Wed, 26 Mar 2014 09:10:37 -0600

I'm able to run more than one instance of ConvertFieldsToTexture on our test machine. I've included the glxinfo from the GTX 650 card, which is now using NVIDIA's proprietary drivers. I could try running some of your networks to see if they'll work on our machine.


Attachment: gtx650_glxinfo
Description: Binary data


PNG image

On Mar 25, 2014, at 4:18 PM, Hyde, Damon wrote:

Now I'm just getting some very bizarre behavior:

When I load the net that Ayla sent, everything works fine.  ConvertFieldsToTexture runs, and I can visualize the torso data.  I can also load up any of my .nrrds, convert them to textures and visualize them just fine.

However, if I add a second ConvertFieldsToTexture module to the net and attempt to run it, it doesn't complete.  Same data, different copies of the same module.  One completes and the other doesn't.  Likewise loading my previously saved nets (that I have used numerous times before) and trying to run them also fails.


On 03/25/2014 05:28 PM, Ayla Khan wrote:
Hi Damon,

We have a test machine running CentOS 6.4 with an NVIDIA GTX 650 card. I can run ConvertFieldsToTexture on it successfully on a small representative dataset, as you can see from the attached screen capture. Unfortunately the drivers that are currently installed are the default nouveau drivers, but I've asked our IT department to switch to the proprietary NVIDIA drivers. In the meanwhile, can you try another dataset? I've attached the network I used, which uses data from the standard SCIRunData download and is set up to read data from the directory pointed to by the SCIRUN_DATA environment variable.


On Mar 25, 2014, at 10:40 AM, Hyde, Damon wrote:

Hey Tom,
  glxgears runs just fine.  I tried turning SLI off, but am still
having the same issue with ConvertFieldsToTexture.  The pipeline I'm
using currently looks like:

ReadField -> SubsampleStructuredFieldByIndices -> ConvertFieldsToTexture

I'm using the second module to chop out most of the data in the NRRD,
leaving just a 5x5x5 volume.

Attached is the output of glxinfo.


On 03/25/2014 11:46 AM, tom fogal wrote:
Hi Damon!

Does 'glxgears' work?

Given that the second cards are teslas, you probably want to disable
SLI.  Try:

  nvidia-xconfig --sli=off

I believe you need to restart your X server after you do that.

If you have no luck there, posting the output of 'glxinfo' to the list
may be useful.  Make sure to capture both stdout && stderr when logging
it.  IIRC glxgears and glxinfo are in the 'glx-utils' package on RH/CentOS.

All that said, if 'ShowField' is working then your OpenGL setup is
probably okay.  Might just be a bug in ConvertFieldsToTexture.  Reducing
the pipeline as much as possible and using a (faked) tiny data file
would probably help debug.


On 03/24/2014 08:28 PM, Hyde, Damon wrote:
I'm having some issues with SCIRun that I believe are related to the
video drivers and OpenGL.  Specifically, I have compiled SCIRun 4.7 on a
workstation running CentOS 6.5.  The build script completes, and SCIRun
opens fine.  I'm using ReadField to input a NRRD file, and can visualize
it with showField.

The issue arises with ConvertFieldsToTexture.  The module seems to start
running, but never completes (or even shows a bit of progress).  From
looking at the documentation a bit, it seems that this module relies on
OpenGL to run properly?

The workstation I'm running on has not one, but three different NVIDIA
cards installed in it.  A Quadro 6000 card and two Tesla 2050 cards.
I've tried compiling SCIRun with the drivers from the CUDA toolkit, as
well as the standalone NVIDIA drivers.  Everything seems to check out as
far as having the drivers installed properly, but I'm guessing my issues
with SCIRun somehow stem from the unusual configuration.   Does anyone
have ideas for a potential solution to this issue?

Also just tried this with the latest trunk release and got the same issues.



Archive powered by MHonArc 2.6.18.

Top of page